d

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore.

15 St Margarets, NY 10033
(+381) 11 123 4567
ouroffice@aware.com

 

KMF

WordPress Gutenberg 10.2 Causing Fatal Errors

WordPress publishers are discovering that Gutenberg 10.2 (released March 17, 2021) is causing “fatal errors” due to a WordPress incompatibility issue.  One publisher suggested that Gutenberg autoupdates should do a compatibility check and trigger a warning if the incompatibility exists.

WordPress Gutenberg

Gutenberg is a visual WordPress site editor that represents a radical departure from how websites were built natively within the WordPress core.

It allows publishers to create sites using graphic user interface of blocks. For example, a web page can be visualized as blocks representing the top of the page (header), the content area, sidebar, etc.

Advertisement

Continue Reading Below

Gutenberg is not yet finished, full site editing capability is still on the way. So naturally as a not yet mature technology bugs are to be anticipated, if not expected.

Gutenberg 10.2 Fatal Error

A member of the Advanced WordPress Facebook Group started a discussion to document a fatal error encountered when updating to Gutenberg 10.2.

The post stated that the fatal error manifested in WordPress version 5.6. It was also noted that a GitHub post on the error noted that Gutenberg 10.2 is not compatible with WP 5.5, either.

WordPress and Gutenberg Release Timeline

WordPress 5.7 was released on March 9, 2021.

The Gutenberg 10.2 site editor was released a little over a week later on March 17, 2021.

Gutenberg site publishers who updated to WordPress 5.7 and then updated to Gutenberg 10.2 should not be seeing this error.

Advertisement

Continue Reading Below

However publishers who updated to Gutenberg 10.2 but not WordPress itself may experience the fatal error.

The fatal error is particularly prone to happen to publishers who set their Gutenberg installations to automatically update (autoupdate) but aren’t set up to autoupdate WordPress itself.

An error was noted in the official Gutenberg WordPress support forums but at the time of this writing there was no follow up.

The fatal flaw issue was also documented on the official Gutenberg GitHub page.

From the GitHub report:

“After updating to 10.2.0 I got an email about a technical issue with the plugin:

An error of type E_ERROR was caused in line 59 of the file… I was able to de-activate the plugin via ftp. Now I don’t want to activate it until I know this has been addressed.”

Another person posted that they noticed the same thing and posted a screenshot:

Screenshot of WordPress Gutenberg fatal error

The user who published the screenshot followed up with:

“I was running WordPress 5.6. After the upgrade to 5.7, everything started working as expected.”

The person who initiated the original GitHub post affirmed that this was their issue as well.

Advertisement

Continue Reading Below

“Thanks for letting me know about 5.7. I hadn’t updated WP either, now I can re-activate Gutenberg.”

Gutenberg 10.2 Incompatible with Older Versions of WordPress

Another GitHub Gutenberg report highlighted that Gutenberg 10.2 caused fatal errors in older versions of WordPress.

A publisher using WordPress version 5.5.3 also reported a fatal error that caused a crash.

The person reporting the issue confirmed that it was specific to Gutenberg 10.2, stating:

“I deactivated the Gutenberg plugin 10.2.0. When I tried to reactivate the plugin the fatal error came back.

Fatal error: Uncaught Error: Class 'WP_Block_Supports' not found in..."

The person made a helpful observation and suggestion that Gutenberg 10.2 should not be allowed to update (or autoupdate) on WordPress versions less than WP 5.7.

“It should not be possible for autoupdating Gutenberg plugin on an older WP site. As the result seems to create a fatal error. As there can be a lot of sites that will come across this problem.”

Advertisement

Continue Reading Below

That is a good solution to the problem! If a known incompatibility exists between Gutenberg 10.2 and older versions of WordPress then it makes sense that autoupdates in those situations will stop and generate a warning of an incompatibility.

Users of Gutenberg site editor who are publishing with a version of WordPress that is older than WP 5.7 are may consider it prudent to update to the latest version before updating to Gutenberg 10.2.

Citations

GitHub:
Gutenberg 10.2.0 Locked Caused a Fatal Error #29977

GitHub:
Fatal Error in Gutenberg Plugin 10.2.0 #29972

Facebook: Advanced WordPress Group (group membership required to View)
FYI, the Latest Gutenberg plugin 10.2 Update Will Cause a Fatal Error


Credit: Source link

Previous Next
Close
Test Caption
Test Description goes like this